httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl...@gmx.de
Subject Sporatische unerklaerbare 403 Fehler
Date Wed, 28 Nov 2007 14:55:51 GMT
Hab seit ein paar Monaten einen neuen Server aufgesetzt und ganz sonderbare Fehler.

Bei so ziemlich jedem VHost kommen immer mal wieder 403-Fehler. Das unerklaerbare daran ist,
das nach 1-2 Minuten warten genau der selbe Link wieder funktioniert (genau wie vor dem 403
auch). 

Und es ist an den meisten Stellen nicht reproduzierbar. Im Backend von Typo3 hab ich manche
Stellen gefunden wo es Reproduzierbar ist.

Das sieht dann so aus, das das anzeigen der Seite funktioniert und der naechste Klick (egal
wohin) einen 403 bringt. Danach kommt ueberall nur noch 403. Nach warten von 1-2 Minuten geht
alles wieder bis auf alles nach dem Klick auf die bestimmte Seite. 

Alle stellen wo das Problem auftritt haben nichts gemeinsamm. Anzeigen von verschiedenen Seiten
im Seitenbaum, genauso wie an diversen Stellen die Bildvorschau.


Die combined log zeigt dabei :
89.13.46.139 - - [28/Nov/2007:13:07:48 +0100] "GET /typo3/db_list.php?id=316 HTTP/1.1" 200
107347 "http://XXXX.de/typo3/alt_db_navframe.php??currentSubScript=db_list.php"
[...]
89.13.46.139 - - [28/Nov/2007:13:07:55 +0100] "GET /typo3/db_list.php?id=316 HTTP/1.1" 403
1196 "http://XXXX.de/typo3/alt_db_navframe.php??currentSubScript=db_list.php" 


in der errorlog zeigt er (bei der funktionierenden Seite, genauso wie beim 403):
[Wed Nov 28 13:07:48 2007] [error] [client 89.13.46.139] client denied by server configuration:
/var/www/virtual/XXXX/htdocs/typo3/thumbs.php, referer: http://XXXX/typo3/
db_list.php?id=316


Die relevanten VHost Eintraege sehen so aus:

    DocumentRoot    /var/www/virtual/XXXX/htdocs
    <Directory /var/www/virtual/XXXX/>
        AddHandler fcgid-script .php
        FCGIWrapper /var/www/fcgi/stadtmission-butzbach.de/php5-fcgi-starter .php
        Options -Indexes Includes FollowSymLinks MultiViews +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>



Ich hab debuggt was mir nur eingefallen ist, mir einen Wolf gegoogelt und nichts gefunden.

Das einzige war ein Beitrag in dieser Liste der aber nicht geloest wurde,  oder eine andere
Ursache hatte: http://www.mail-archive.com/users-de@httpd.apache.org/msg04180.html


Ich hoffe wirklich jemand hat einen Tip zum weitersuchen.


:thorsten


-- 
Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message