httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Dittrich <max.dittr...@t-online.de>
Subject Re: mod_ssl: HTTP und HTTPS gleichzeitig auf Port 443?
Date Sat, 23 Dec 2006 09:56:35 GMT
Hi,

Marcus Reimann schrieb:

> 
> Du hast in Deinem Eingangsposting geschrieben:
>> Nunmehr wider Erwarten bekomme ich jedoch "Error 400 / Bad
>> request".
> 
> Das ist genau die Fehlermeldung, die der Apache schickt,
> weil Du auf die Resource _ohne_ SSL zugreifen möchtest. Der
> Apache verhält sich in Deinem Fall also genauso, wie Du ihn
> konfiguriert hast:
> 1. Du hast Deinem Apache gesagt "SSLRequireSSL" (zum Zugriff
>    auf die Resource ist SSL notwendig)
> 2. Du rufst die Resource ohne SSL auf (Du verwendest in
>    Deinem Beispiel "http", nicht "https").
> 3. Ergebnis: Die Auslieferung ohne SSL wird unterbunden
>    (forbidden) und stattdessen gibt's ne Fehlermeldung.
> 

Will hier nur noch auf eine kleine lustige Beobachtung hinweisen, auf 
die ich aufmerksam wurde.

Diese Fehlerseite "Bad Request!", die man zu sehen bekommt wenn man 
einen HTTPS-Server per HTTP anspricht, wird vom Apache ohne HTTP-Header 
geschickt. Es kommt sozusagen nur der Response-body.

Vielleicht hat einer der Mitlesenden im Kopf seit welcher Version dieses 
Verhalten existiert.

Schöne Grüsse,
.max


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message