httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Rasche <ph...@raschesweb.de>
Subject Re: AW: Apache hängt im Status "Sending Reply"
Date Wed, 06 Dec 2006 23:55:36 GMT
MacGyver schrieb am 07.12.2006 00:15:
> Die Laufzeiten die ich protokoliert habe liegen immer im < 5 Sekunden
> Bereich - Die Seite braucht aber auch gern schonmal 30 Sekunden und
> länger bis sie auf meinem Client geladen ist.
> 
> Die Zeit dazwischen hätte ich halt gern noch als "normal" oder "da läuft
> noch was schief" ausgeschlossen bzw. bestätigt.

Ich halte beide Werte für extrem.
Scriptlaufzeiten von mehren Sekunden sind schon an sich viel zu
hoch. Wobei sich das natürlich durch die hohe Load schon erklären
lässt, sofern die Laufzeiten unter Halblast wesentlich darunter
liegen (< 1 Sekunde).
Sind da möglicherweise noch mod_gzip oder in php output_compression
aktiviert, die den Apache zusätzlich beschäftigen?
Komplexe Rewrite-Regeln, die der Apache erst noch parsen muss?

>> Der eAccelerator macht das was er soll?
>>   
> Wenn ich ihn abschalte, dann ist es fast sofort vorbei mir Arbeiten auf
> dem Server.

D.h. load steigt weiter?

Dein Netzwerkinterface kannst du als Flaschenhals ausschliessen?
Wenn MySQL zusätzlich zu den HTTP-Requests über ein Interface
laufen, würde ich das (bzw. die Netzanbindung) mal kontrollieren
(Sorry, falls du das auch schon gemacht hast ;) )

Gruß
Frank

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message