httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arne Heizmann <Arne.Heizm...@csr.com>
Subject Apache startet nicht, keine Fehlermeldungen
Date Tue, 10 Oct 2006 17:50:09 GMT

Hallo,

ich verwende Apache2 unter Windows 2000.

Seit heute weigert sich Apache, zu starten. Es gibt keine 
Fehlermeldungen. Die Datei error.log ist leer. access.log auch.

Ein Versuch, Apache mit "-e debug" auf der Kommandozeile zu starten, 
liefert lediglich folgendes:

> C:\Programme\Apache Group\Apache2\bin>Apache.exe -n Apache2Support -k restart -e debug
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module access_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module alias_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module autoindex_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module dir_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module log_config_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module mime_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module negotiation_module
> [Tue Oct 10 18:39:08 2006] [debug] mod_so.c(248): loaded module setenvif_module

Der Apache Service Monitor, also dieses kleine Windows-GUI, sagt nur: 
"The requested operation has failed!".

Wie komme ich dem Problem also auf die Schliche, wenn nirgends eine 
Fehlermeldung ausgegeben wird?

Ich habe die httpd.conf unten wiedergegeben.

Antworten auf eventuelle Fragen, die ich mir schon denken kann:
  * Existiert das Verzeichnis C:\bug? => Ja.
  * Gucke ich vielleicht in der falschen error.log? => Es wurde keine
    .log-Datei irgendwo auf C: verändert.
  * Was habe ich gemacht, als es aufhörte zu funktionieren? => Ich habe
    C:/bug in X:/bug geändert (an beiden Stellen) (und ja, X:/bug
    existiert auch), seitdem geht es nicht mehr, auch nicht mehr mit
    C:/bug.

Danke im Voraus,
Arne





ServerRoot "C:/Programme/Apache Group/Apache2"
PidFile logs/httpd.pid
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
Listen 80
ServerName localhost

LoadModule access_module modules/mod_access.so
LoadModule alias_module modules/mod_alias.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule dir_module modules/mod_dir.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule setenvif_module modules/mod_setenvif.so

ServerAdmin Arne.Heizmann@csr.com

UseCanonicalName Off

DocumentRoot "C:/bug"

<Directory />
     Options FollowSymLinks
     AllowOverride None
</Directory>

<Directory "C:/bug">

     Options Indexes FollowSymLinks

     AllowOverride None

     Order allow,deny
     Allow from all

</Directory>

DirectoryIndex index.html
AccessFileName .htaccess
TypesConfig conf/mime.types
DefaultType text/plain
HostnameLookups Off

ErrorLog logs/error.log
LogLevel warn
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

CustomLog logs/access.log common

ServerTokens Full
ServerSignature On
ForceLanguagePriority Prefer Fallback
AddDefaultCharset UTF-8


To access the latest news from CSR copy this link into a web browser:  http://www.csr.com/email_sig.php

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message