httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Puschmann <...@uzulabs.net>
Subject Re: setlocale ro_RO
Date Thu, 26 Oct 2006 11:00:35 GMT
On Thu, Oct 26, 2006 at 12:33:35PM +0200, Sebastian Kayser wrote:
> * Paul Puschmann <lnx@uzulabs.net> wrote:
> > On Thu, Oct 26, 2006 at 02:43:10AM +0200, René Thiel wrote:
> > > wer produziert hier diesen Fehler: Linux, Apache oder PHP?
> > > http://ro-portal.net/strftime1.php
> > > setlocale(LC_ALL, "ro_RO.ISO8859-2");
> > > echo strftime("%A", strtotime("10/28/2006"));
> > > 
> > > Sîmb??t?? ist definitiv falsch.
> > > Unter Windows bekomme ich: sâmbata, was schon etwas besser ist,
> > > korrekt wäre aber: Sâmb??t??
> > > 
> > > Ich hoffe, die Sonderzeichen kommen jetzt korrekt an...
> > hast du schonmal LC_LANG probiert?
> 
> Der Vollständigkeit halber. Unterschied LC_LANG, LC_ALL:
> 
> - LC_ALL schreibt den Wert für alle LC_-Variablen vor.
> - LC_LANG ist ein Default-/Fallback-Wert für alle ungesetzten LC_-Variablen.
> 
> Insofern macht das keinen Unterschied.
> 
> Weiterhin: Bei der Ausgabe von locale werden die Werte der über LC_LANG
> definierten Variablen in Anführungszeichen gesetzt. Alle explizit bzw.
> insofern über LC_ALL gesetzten Werte werden nicht in Anführungszeichen
> gesetzt.
> 
Jepp.

Ich könnte mir halt vorstellen, dass es hier schon ab und zu
unterschiedliche Ausgaben gibt.

Paul
-- 
: Bitte einen Realname benutzen, unter dem Zitat antworten
: und einfache Text-Mails senden (kein HTML).
: Danke.

Mime
View raw message