httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Weh <reinhard....@baeurer.de>
Subject mod_auth_ldap Problem apache2
Date Thu, 04 May 2006 15:38:47 GMT
Hallo,

ich versuche schon länger per mod_auth_ldap auf unseren Openexchange LDAP server zu connecten
folgende Konfiguration

Apache 2.0.49 (auf einem SuSE Linux Enterprise Server 9 mit allen Hotfixes)

.htaccess

AuthType Basic
AuthName "LDAP auth"
AuthLDAPEnabled on
AuthLDAPURL ldap://s0134.server.ds:389/ou=people,dc=baeurer,dc=de?uid?sub?(objectClass=*)
require valid-user

Fehlermeldung des Apache2 error_log
[Thu May 04 09:44:54 2006] [warn] [client 172.23.1.22] [2583] auth_ldap authenticate: user
weh
authentication failed; URI /access/ [User not found][No such object]

Wenn ich auf der shell folgendes eingebe funktioniert es:

s0130:/srv/www/htdocs/access # ldapwhoami -h ldap.server.ds -x -D
"uid=weh,ou=people,dc=baeurer,dc=de" -W
Enter LDAP Password:
dn:uid=weh,ou=people,dc=baeurer,dc=de

ich habe auf dem ldap Server auch schon den debug level erhöht, und beim connect per mod_auth_ldap
kommt dann folgendes:

May  4 14:03:18 s0134 slapd[5494]: => str2entry: "dn: uid=weh,ou=people,dc=baeurer,dc=de
structuralObjectClass: inetOrgPerson entryUUID: 09e77b30-aa8a-1029-839d-a0368c49c935 creatorsName:
uid=mailadmin,ou=people,dc=baeurer,dc=de createTimestamp: 20050826143256Z objectClass: top
objectClass: shadowAccount objectClass: posixAccount objectClass: person objectClass: inetOrgPerson
objectClass: OXUserObject objectClass: organizationalPerson homeDirectory: /home/weh mailEnabled:
OK
uid: weh OXAppointmentDays: 10 OXDayviewStartTime: 7:00 sn: Weh mailDomain: baeurer.de alias:
reinhard.weh@baeurer.de
May  4 14:03:18 s0134 slapd[5494]: >>> dnPrettyNormal: <uid=weh,ou=people,dc=baeurer,dc=de>
May  4 14:03:18 s0134 slapd[5494]: <<< dnPrettyNormal: <uid=weh,ou=people,dc=baeurer,dc=de>,
<uid=weh,ou=people,dc=baeurer,dc=de>
May  4 14:03:18 s0134 slapd[5494]: >>> dnNormalize: <uid=mailadmin,ou=people,dc=baeurer,dc=de>
May  4 14:03:18 s0134 slapd[5494]: <<< dnNormalize: <uid=mailadmin,ou=people,dc=baeurer,dc=de>
May  4 14:03:18 s0134 slapd[5494]: >>> dnNormalize: <uid=weh,ou=people,dc=baeurer,dc=de>
May  4 14:03:18 s0134 slapd[5494]: <<< dnNormalize: <uid=weh,ou=people,dc=baeurer,dc=de>
May  4 14:03:18 s0134 slapd[5494]: <= str2entry(uid=weh,ou=people,dc=baeurer,dc=de) ->
0x81bf400
May  4 14:03:18 s0134 slapd[5494]: <= id2entry_r( 77 ) 0x81bf400 (disk)
May  4 14:03:18 s0134 slapd[5494]: => string_expand: pattern:  127.*.*.*
May  4 14:03:18 s0134 slapd[5494]: => string_expand: expanded: 127.*.*.*
May  4 14:03:18 s0134 slapd[5494]: => regex_matches: string:     IP=172.23.0.19:1457
May  4 14:03:18 s0134 slapd[5494]: => regex_matches: rc: 1 no matches
May  4 14:03:18 s0134 slapd[5494]: => string_expand: pattern:  127.*.*.*
May  4 14:03:18 s0134 slapd[5494]: => string_expand: expanded: 127.*.*.*
May  4 14:03:18 s0134 slapd[5494]: => regex_matches: string:     IP=172.23.0.19:1457
May  4 14:03:18 s0134 slapd[5494]: => regex_matches: rc: 1 no matches
May  4 14:03:18 s0134 slapd[5494]: ldbm_search: candidate entry 77 does not match filter
May  4 14:03:18 s0134 slapd[5494]: ====> cache_return_entry_r( 77 ): created (0)
May  4 14:03:18 s0134 slapd[5494]: send_ldap_result: conn=2 op=1 p=3

Was mache ich falsch ?
Hat das jemand am laufen und kann mir einen Tipp geben

--
Gruß
Reinhard Weh


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message