httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henk Strobel / netwood <stro...@netwood.de>
Subject Re: AW: Apache Prozesse unter Windows Server 2003
Date Thu, 19 Jan 2006 14:35:43 GMT
Hallo,

hier die Teile der httpd.conf, die ich für relevant halte:

[...]

<IfModule mpm_winnt.c>

# geaendert auf 1000 20051128, war: 250
# geaendert auf 5000 20060118
ThreadsPerChild 5000
#ThreadLimit 5000
MaxRequestsPerChild  0
</IfModule>

[...]

LoadModule php4_module "c:/php/sapi/php4apache2.dll"
LoadFile "c:/perl/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so

[...]

AddType application/x-httpd-php .php

[...]

AddHandler cgi-script .cgi .pl

[...]


Es gibt einige virtuelle Hosts, auf einem wird SSL genutzt.
Experimente mit ThreadsPerChild zusammen mit ThreadLimit haben zu 
merkwürdig instabilem Verhalten geführt (Der Serer hat nach kürzester 
Zeit keine Anfragen beantwortet, deshalb habe ich das erst einmal 
gelassen...


Viele Grüße

Henk Strobel



Meißner schrieb:
> hi,
> wie sieht denn die config dazu aus ?
> bevor wir in die glaskugel blicken muessen ...
> fragende grüße
> h1 
> 
> -----Ursprüngliche Nachricht-----
> Von: Henk Strobel / netwood [mailto:strobel@netwood.de] 
> Gesendet: Mittwoch, 18. Januar 2006 12:06
> An: users-de@httpd.apache.org
> Betreff: Apache Prozesse unter Windows Server 2003
> 
> Hallo,
> 
> ich habe ein Problem mit dem Apache 2.0.50 auf Windows Server 2003:
> 
> Es kommt immer wieder vor - offenbar zu Stoßzeiten - das der Server 
> nicht auf Anfragen reagiert. Zu diesem Zeitpunkt sind in der Prozeßliste 
> 3 Apache-Prozesse zu sehen. Wenn man versucht, den Apache neu zu 
> starten, bleibt ein Prozess bestehen. Zu anderen Zeitpunkten (wenn der 
> Server normal lief) habe ich bisher immer nur zwei Apache-Prozesse gesehen.
> 
> Meine Theorie ist, das der Apache es aus irgendwelchen Gründen es nicht 
> schafft, einen neuen Prozess zu starten, wenn ThreadsPerChild erreicht 
> ist, bzw. sich dieser Prozess sofort aufhängt. In den Apache- und 
> Systemlogs ist nichts zu finden. Habe ThreadsPerChild auf 1000 erhöht, 
> das Problem tritt trotzdem auf.
> 
> Hat jemand eine Idee? Es handelt sich um eine Maschine mit 4 Prozessoren 
> und 4 GB RAM.
> 
> Viele Grüße
> 
> Henk Strobel
> 
> --------------------------------------------------------------------------
>                 Apache HTTP Server Mailing List "users-de" 
>       unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>            sonstige Anfragen an users-de-help@httpd.apache.org
> --------------------------------------------------------------------------
> 
> 
> --------------------------------------------------------------------------
>                 Apache HTTP Server Mailing List "users-de" 
>       unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>            sonstige Anfragen an users-de-help@httpd.apache.org
> --------------------------------------------------------------------------
> 
> 
> 
> 

-- 
Henk Strobel / webentwicklung
netwood new media services GmbH
---------------------------------------------
Georgstr. 56
30159 Hannover
fon: +49 (0)511 28061 304
fax: +49 (0)511 28061 310
email: strobel@netwood.de


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message