httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Schaedler <li...@daniel.schaedler.name>
Subject Re: Apache startet nicht als Windows-Dienst - auf cmd aber schon
Date Tue, 03 Jan 2006 12:03:39 GMT
Paul Puschmann wrote:
> Daniel Schaedler wrote:
>> Hallo und ein gutes neues Jahr!
>>
>> Ich habe Apache 2.0.55 auf Windows installiert; mod_proxy_html eingefügt
>> und über die Kommandozeile gestartet. Alles bestens soweit.
>> Soll Apache aber als Window-Dienst gestartet werden, bekomme ich den
>> Fehler:
>> The Apache service named  reported the following error:
>>>>> Cannot load C:/Programme/Apache/Apache2/modules/mod_proxy_html.so
>> into server: Das angegebene Modul wurde nicht gefunden.
>>
>> Das mod_proxy_html.so modul ist vorhanden (über die Kommandozeile
>> klappts ja). Die Berechtigungen habe ich überprüft: alle Moduldateien
>> dürfen gelesen und ausgeführt werden vom Benutzer, der im Dienststart
>> angegeben ist.
>> Gebe ich beim Dienst den selben Benutzer an, mit dem ich auf der
>> Kommandozeile starte, dann startet der Dienst auch (will ich aber aus
>> Sicherheitsgründen nicht).
>> Irgendwie muss es mit Berechtigungen zusammenhängen, bloss mit welchen??
>>
>> jemand eine Idee woran das liegen könnte?
>>
>> viele Grüsse
>> Daniel
> Vielleicht ist der Pfad nicht richtig gesetzt?
> Wenn du die .cmd aufrufst, bist du ja im entsprechenden
> Apache-Verzeichnis. Wie sieht das denn bei deinem Service aus?

Die Pfade müssen stimmen, denn vor dem mod_proxy_html werden eine ganze 
Menge anderer Module erfolgreich geladen.

> Wenn du vermutest, dass es an den Benutzerrechten liegt: Du kannst einen
>  Dienst ja unter einer bestimmten Benutzerkennung ausführen...

genau. Er startet auch, wenn ich ihn als Admin starte (das ist aber 
wirklich keine Option).

Wenn ich mich unter dem Benutzer anmelde, unter dem der Dienst starten 
soll, dann bekomme ich die selbe Fehlermeldung.
Ich habe nochmals sämtliche Rechte mit Cygwin überprüft und kann keine 
Unterschiede feststellen zwischen den Modulen, die geladen werden und 
mod_proxy_html. Sämtliche Module sind für lesen/ausführen freigegeben 
(ebenfalls die zugehörigen .dlls)

stehe irgendwie immer noch am Berg :-(

viele Grüsse
Daniel

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message