httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Drebert <drebe...@web.de>
Subject Merkwuerdiges Verhalten bei SetEnvIf Request_URI (geloest)
Date Fri, 09 Sep 2005 06:05:57 GMT

Hallo

Da ich mich in den letzten Tagen etwas intensiver mit regex beschäftigt habe ist es mir plötzlich
ganz klar wo dran es liegt.
ich darf natürlich ein \ und dahinter einen Buchstaben benutzen, weil es ja dann ein regex
ist,
bei den ersten 3 Verzeichnissen hatte es zufällig gepasst weil die mir \u beginnen, das neue
4te hat aber mit \r begonnen und wurde dadurch nicht erkannt.

>Hallo
>ich schreibe zum einen alle Log Einträge in ein Hauptlogfile und bestimmte
>Verzeichnisse noch mal extra in spezielle Logfiles das mach ich über die 
>SetEnvIf Request_URI Variabel.
>Bei 3 Verzeichnissen sah das so immer aus:
>SetEnvIf Request_URI \verzeichniss1* verzeichniss1
>SetEnvIf Request_URI \verzeichniss2* verzeichniss2
>SetEnvIf Request_URI \verzeichniss3* verzeichniss3
>nun wollte ich ein 4tes hinzufügen und es funktionierte nicht, bis ich mal
>probierte ein / zu nehmen, also
>SetEnvIf Request_URI /verzeichniss4* verzeichniss4
>
>Hat jemand eine Erklärung warum ich bei den ersten 3
>Verzeichnissen ein \ und beim letzten ein / nehmen muß?
>
>Bei mir läuft der Apache V2 unter XP sp2


______________________________________________________________________
XXL-Speicher, PC-Virenschutz, Spartarife & mehr: Nur im WEB.DE Club!		
Jetzt gratis testen! http://freemail.web.de/home/landingpad/?mc=021130


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message