httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Müller <s...@hitnet.rwth-aachen.de>
Subject suexec Problem
Date Mon, 06 Jun 2005 20:57:57 GMT
Hallo zusammen!

Ich hoffe jmd von euch kann mir bei meinem suexec Problem weiterhelfen,
da ich keine Idee mehr habe, was denn falsch ist.

Installiert hab ich den Apache auf meinem FreeBSD System mit suexec:

su-2.05b# httpd -V
Server version: Apache/1.3.33 (Unix)
Server built:   Apr 17 2005 16:35:35
Server's Module Magic Number: 19990320:16
Server compiled with....
 -D EAPI
 -D EAPI_MM
 -D EAPI_MM_CORE_PATH="/var/run/httpd.mm"
 -D HAVE_MMAP
 -D USE_MMAP_SCOREBOARD
 -D USE_MMAP_FILES
 -D HAVE_FLOCK_SERIALIZED_ACCEPT
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D DYNAMIC_MODULE_LIMIT=64
 -D HARD_SERVER_LIMIT=512
 -D SO_ACCEPTFILTER
 -D ACCEPT_FILTER_NAME="httpready"
 -D HTTPD_ROOT="/usr/local"
 -D SUEXEC_BIN="/usr/local/sbin/suexec"
 -D DEFAULT_PIDLOG="/var/run/httpd.pid"
 -D DEFAULT_SCOREBOARD="/var/run/httpd.scoreboard"
 -D DEFAULT_LOCKFILE="/var/run/httpd.lock"
 -D DEFAULT_ERRORLOG="/var/log/httpd-error.log"
 -D TYPES_CONFIG_FILE="etc/apache/mime.types"
 -D SERVER_CONFIG_FILE="etc/apache/httpd.conf"
 -D ACCESS_CONFIG_FILE="etc/apache/access.conf"
 -D RESOURCE_CONFIG_FILE="etc/apache/srm.conf"

Suexec sollte auch laufen, denn wenn ich den Apache starte bekomme ich
folgende Meldung im Logfile:

[Mon Jun  6 20:47:12 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/local/sbin/suexec)

Nun möchte ich meine Perl Scripte im VHost ausführen dafür habe ich
folgende Konfiguration gewählt:

<VirtualHost xxx.xxx.xxx.xxx:80>
  ServerName blabla.de
  User sven
  Group wheel
  Options +ExecCGI FollowSymLinks Includes Indexes MultiViews
  AddHandler cgi-script .cgi .pl
  DocumentRoot /usr/local/www/docs/sven/html/
  ScriptAlias /cgi-bin /usr/local/www/docs/sven/cgi-bin
  CustomLog /usr/local/www/docs/sven/log/access.log meinlog
</VirtualHost>

Das /usr/local/www/docs/sven/cgi-bin sieht wie folgt aus:

su-2.05b# ls -la
total 6
drwxr-xr-x  2 sven  wheel  512 Jun  6 20:51 .
drwxr-xr-x  6 sven  wheel  512 May  5 12:12 ..
-rwxr-xr-x  1 sven  wheel   77 May  5 21:46 test.cgi

Der Inhalt der test.cgi Datei:

su-2.05b# less test.cgi 
#!/usr/bin/perl

print "Content-type: text/html\n\n";
print "Hallo Welt\n";


Ich denke es sollte alles stimmen, aber wenn ich die Datei im Browser
aufrufe bekomme ich immer einen Internal Server Error.

Das Logfiles sagt dazu:

[Mon Jun  6 20:51:22 2005] [error] [client xxx.xxx.xxx.xxx] Premature end
of script headers: /usr/local/www/docs/sven/cgi-bin/test.cgi

Von der Shell aus kann ich das Script ohne Probleme aufrufen:
su-2.05b# ./test.cgi          
Content-type: text/html

Hallo Welt


Hat jmd eine Idee oder einen Tip, mir fällt nix mehr ein?!

Ich wäre sehr dankbar!

Grüße, sVen



--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message