httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ma...@dedenet.de
Subject Problem mit Log und ENV Variablen
Date Fri, 11 Jun 2004 03:36:01 GMT
Hallo,

ich habe die CGI Version von PHP und den cgiwrapper sbox installiert.

Nun stelle ich im Apachen ein, dass php Dateien über den Wrapper abgewickelt werden.

AddHandler sbox .php
Action sbox /cgi-bin/sbox


Jetzt erscheint allerdings das "/cgi-bin/sbox/" auch in der Logdatei.

192.168.0.200 - - [11/Jun/2004:05:15:55 +0200] "GET /cgi-bin/sbox/index.php HTTP/1.1" 400
643 "http://192.168.0.200/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040524
Firefox/0.8"

phpinfo gibt mir unter anderem folgendes aus:

PHP_SELF 	/cgi-bin/sbox/index.php
_SERVER["SCRIPT_NAME"]	/cgi-bin/sbox/index.php
_SERVER["SCRIPT_FILENAME"]	/username/index.php
.
.
.

nun meine Fragen:

a) Was kann ich machen, damit das /cgi-bin/sbox aus der Access Log verschwindet?
b) Was kann man tun, dass die PHP_SELF Variable (und dann am besten auch SCRIPT_NAME) auf
die eigentliche Datei und nicht auf den Wrappe zeigen (also nur /index.php")?


Werden noch weitere Infos benötigt oder kann damit schon jemand etwas anfangen?

Viele Grüße,
Mario Döring.

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message