httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Muller <apa...@universalware.de>
Subject AW: VirtualHost probleme mit apache2 und mod_ssl
Date Tue, 04 May 2004 04:23:26 GMT
Guten morgen,
also wenn ich mich nicht irre ist das Problem recht einfach zu losen:
Die Portangabe muss aus dem Servername raus und an die virtual Host IP ran.

> Listen 80
> Listen 443
> 
> NameVirtualHost 192.168.0.5
> 
> <VirtualHost 192.168.0.5:443>
>   ServerName www.webserve.local
>   DocumentRoot /var/www/localhost-ssl/htdocs
>   SSLEngine On
>   SSLCertificateFile /etc/apache2/ssl/cert.pem
>   SSLCertificateKeyFile /etc/apache2/ssl/cert.key
>   <IfModule mod_setenvif.c>
>     SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown \
>     downgrade-1.0 force-response-1.0
>   </IfModule>
> </VirtualHost>
> 
> <VirtualHost 192.168.0.5:80>
>   ServerName www.webserve.local
>   DocumentRoot /var/www/localhost/htdocs
> </VirtualHost>
> 
> <VirtualHost 192.168.0.5:80>
>   ServerName www.camserve.local
>   DocumentRoot /var/www/camserve/htdocs
> </VirtualHost>

Ist noch fruh am morgen :-)

Gru?,
Andreas


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message