httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Walter Haeuptli" <whaeup...@hotmail.com>
Subject Re: VirtualHost ignoriert
Date Thu, 20 Nov 2003 20:53:55 GMT
Vielen und grossen Dank, Max,

für die schnelle, umfassende und kompetente Auskunft samt möglichen 
Varianten: Ich konnte mein Problem schon heute Nachmittag lösen. Ich hatte 
name based und ip based virtual hosts vermischt. Ein CNAME-Eintrag im DNS 
für jeden domain sowie eine einheitliche Bezeichnung in <VirtualHost 
192.168.1.11> führten zur Erleichterung...

Wünsche einen schönen Abend!

Freundliche Grüsse - Walter Häuptli


>From: Max.Dittrich@t-online.de (Max Dittrich)
>Reply-To: users-de@httpd.apache.org
>To: users-de@httpd.apache.org
>Subject: Re: VirtualHost ignoriert
>Date: Thu, 20 Nov 2003 21:45:20 +0100
>MIME-Version: 1.0
>Received: from mail.apache.org ([208.185.179.12]) by mc8-f12.hotmail.com 
>with Microsoft SMTPSVC(5.0.2195.6713); Thu, 20 Nov 2003 12:45:27 -0800
>Received: (qmail 50293 invoked by uid 500); 20 Nov 2003 20:45:13 -0000
>Received: (qmail 50280 invoked from network); 20 Nov 2003 20:45:13 -0000
>Received: from unknown (HELO mailout03.sul.t-online.com) (194.25.134.81)  
>by daedalus.apache.org with SMTP; 20 Nov 2003 20:45:13 -0000
>Received: from fwd07.aul.t-online.de by mailout03.sul.t-online.com with 
>smtp id 1AMvfy-00060t-00; Thu, 20 Nov 2003 21:45:18 +0100
>Received: from t-online.de 
>(V+OgwwZeZeBb5HpJGLiVTJSX3rYQCM63xwSAZb3gjahrG+Q9WToqkj@[217.232.44.52]) by 
>fwd07.sul.t-online.comwith esmtp id 1AMvfd-0fTMKe0; Thu, 20 Nov 2003 
>21:44:57 +0100
>X-Message-Info: JGTYoYF78jFq8Q9Klz2Ejrky0XJuFZGP
>Mailing-List: contact users-de-help@httpd.apache.org; run by ezmlm
>Precedence: bulk
>list-help: <mailto:users-de-help@httpd.apache.org>
>list-unsubscribe: <mailto:users-de-unsubscribe@httpd.apache.org>
>list-post: <mailto:users-de@httpd.apache.org>
>Delivered-To: mailing list users-de@httpd.apache.org
>Message-ID: <3FBD27E0.5060306@t-online.de>
>User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) 
>Gecko/20030624
>X-Accept-Language: de, en-us, en
>References: <BAY99-F54bTrvz0vogb0000730d@hotmail.com>
>In-Reply-To: <BAY99-F54bTrvz0vogb0000730d@hotmail.com>
>X-Seen: false
>X-ID: V+OgwwZeZeBb5HpJGLiVTJSX3rYQCM63xwSAZb3gjahrG+Q9WToqkj
>X-Spam-Rating: daedalus.apache.org 1.6.2 0/1000/N
>Return-Path: users-de-return-2227-whaeuptli=hotmail.com@httpd.apache.org
>X-OriginalArrivalTime: 20 Nov 2003 20:45:28.0984 (UTC) 
>FILETIME=[3B8A8980:01C3AFA7]
>
>Hallo,
>
>Walter Haeuptli wrote:
>>Ich laufe Apache 2.0 und habe folgendes Problem: Der Zugriff erfolgt immer 
>>gegen den VirtualHost _default_, obwohl ich lokale tcp/ip Nummern für 
>>meine offiziellen domains vergab.
>>
>>Beispiel: Hier die Konfiguration von _default_ und einem domain
>>
>><VirtualHost _default_:*>
>>ServerName                                                                 
>>           192.168.1.11
>>VirtualDocumentRoot /hd1
>   ^^^^^^^
>ui  :)
>
>>ErrorLog /home/walter/logs/error_log
>>CustomLog /home/walter/logs/access_log common
>></VirtualHost>
>>
>><VirtualHost 192.168.1.24>
>>ServerName                                                                 
>>    new.livingsites.com
>>ServerAlias new.livingsites.com *.new.livingsites.com
>>DocumentRoot /hd1/vhosts/new.livingsites.com/httpdocs
>>ErrorLog /home/walter/logs/error_log
>>CustomLog /home/walter/logs/access_log common
>></VirtualHost>
>
>Ist der VirtualHost namens- oder ip-basiert?
>
>>
>>Nun das Resultat der Abfrage (wget von einem anderen Server aus):
>>
>>%rm a.html ; wget -Oa.html new.livingsites.com ; cat a.html
>
>alternativ:
>
>   % lynx -mime_header -source http://new.livingsites.com/a.html
>
>>--11:58:00--  http://new.livingsites.com/
>>            => `a.html'
>>Connecting to new.livingsites.com:80... connected!
>>HTTP request sent, awaiting response... 403 Forbidden
>>11:58:01 ERROR 403: Forbidden.
>>
>>Meine Untersuchung ergab, dass der Zugriff über _default_ statt 
>>new.livingsites.com erfolgte und das "Forbidden" entstand, weil auf dem 
>>dortigen DocumentRoot /hd1/vhosts tatsächlich keine Leseberechtigung 
>>besteht.
>>Frage: Warum ignoriert apache den canonical name new.livingsites.com? Was 
>>mache ich falsch? Wie kriege ich den VirtualHost aktiv?
>
>Schliesse clientseitige DNS-Probleme aus, da nach der Dokumentation ein 
>_default_ Server u.a. nur ausgewählt wird, wenn zu der IP-Adresse kein 
>VirtualHost definiert ist. Dazu könntest Du eine telnet-Anfrage mit dem 
>Inhalt
>
>telnet 192.168.1.24 80
>
>HEAD /a.html HTTP/1.1
>Host: new.livingsites.com
>Connection: close
>
>machen.
>
>Da Du kein getrenntes access_log führst solltest Du Dein LogFormat um %v 
>erweitern. Dieser Eintrag sollte Dir dann Aufschluss über den Host ( = 
>ServerName ) geben, der die Anfrage bearbeitet hat.
>
>>
>>Danke zum voraus der/m Prinzen/essin, der/die mich aus diesem 
>>Dornenschloss erlöst!
>
>Mal sehen, ob Dich mein Beitrag aufgeweckt hat. Ich denke nicht. :)
>
>gruss,
>.max
>
>
>--------------------------------------------------------------------------
>                Apache HTTP Server Mailing List "users-de"      
>unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
>           sonstige Anfragen an users-de-help@httpd.apache.org
>--------------------------------------------------------------------------
>

_________________________________________________________________
The new MSN 8: advanced junk mail protection and 2 months FREE* 
http://join.msn.com/?page=features/junkmail


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message