httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manfred Gnädig <rp40...@rp-plus.de>
Subject AW: AW: AW: AW: Irgendetwas stoppt dasAusführen der CGI´s
Date Mon, 24 Nov 2003 00:55:06 GMT
Hallo Harald,
nochmals herzlichen Dank für deine Hilfe.

Ich habe heute Abend etwas beobachtet.

In meiner httpd.conf stand:

MaxClients          330
MaxRequestsPerChild 330

Sobald laut Apache Server Status 
250 requests currently being processed überschritten werden,
stellen die CGI´s Ihren Dienst ein.

Ich habe jetzt diese Werte auf 250 gesetzt.
Klar, jetzt gehen nicht mehr als 250 requests,
aber die CGI sind nicht mehr ausgegangen.

Das ist ja auch schon mal ein kleiner Fortschritt. (;-))

Ich sehe schon, ab 256 MaxClients wird es kompliziert.
Wenn ich den Wert höher setze, werden nur noch html Seiten ausgeliefert
Bei CGI´s kommt ein ERROR.

Gibt es eine Möglichkeit herauszufinden, mit welchem Wert
HARD_SERVER_LIMIT
mein Apache Compiliert worden ist? 

Ich dachte das wäre standardmäßig auch 256.
Deswegen wundert es mich, dass bei mir überhaupt 256 requests currently
being prozessed überschritten werden können. Wenn auch mit dem CGI
Problem.

Danke für die Erklärungen zu ulimit -a
Ich habe das Script jetzt auf allen Servern.
Die Sache mit dem apache Startscript habe ich auch schon ausprobiert.
Das funktioniert soweit alles wunderbar.

Ich habe mich aber noch nicht getraut MaxClients auf einen Wert von über
256 zu setzen.

Liebe Grüße und danke für alles
Manfred





--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message