httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "t-systems-fitz" <t-systems-f...@web.de>
Subject Re: Probleme mit mod_proxy unter Apache 2.0.47
Date Tue, 26 Aug 2003 07:26:27 GMT
Hallo,

neue Infos.

Ich habe mir alles noch mal genauer angeschaut und herausgefunden, dass
strncmp einen case sensitiven Vergleich macht.
In meiner httpd.conf stand ProxyPassReverse / http://www.xxx.xx
Der eigentliche Webserver hat aber ein redirect auf http://Www.xxx.xx
gemacht, damit ist aber die Bedingung strncmp(ent[i].real, url, l2) == 0
nicht mehr erfuellt und die Location im http-Header wurde nicht ersetzt.

Nach meiner Meinung sollten aber URL's case insensitive verglichen werden.

Irgendwelche Meinungen dazu ????

mfg fitz

----- Original Message -----
From: "t-systems-fitz" <t-systems-fitz@web.de>
To: <users-de@httpd.apache.org>
Sent: Wednesday, August 20, 2003 3:02 PM
Subject: Re: Probleme mit mod_proxy unter Apache 2.0.47


> Hallo,
>
> ich bin mal in die Tiefen des Codes eingestiegen und habe festgestellt,
das
> in der Funktion  "static const char *ap_proxy_location_reverse_map" in der
> Datei
>
> modules/proxy/proxy_http.c, im HTTP-Header Location neu gesetzt wird.
> Allerdings existiert dort die Bedingung:
>
> if (l1 >= l2 && strncmp(ent[i].real, url, l2) == 0), die bei mir nie war
ist
> (wegen strncmp!=0).  Da habe ich kurzerhand die Bedingung durch if(l1 >=
l2)
> ersetzt und damit hat es dann funktioniert.
>
> Mich macht allerdings stutzig, dass im 1.3.27 die Funktion fast identisch
> ist und da funktioniert es ja trotz dieser Bedingung.
>
> Vielleicht hat ja jemand Lust, sich damit näher zu beschäftigen. Ich wäre
> dankbar über mehr Infos.
>
> mfg fitz
>
>
>
> ----- Original Message -----
> From: "t-systems-fitz" <t-systems-fitz@web.de>
> To: <    >
> Sent: Wednesday, August 20, 2003 1:00 PM
> Subject: Probleme mit mod_proxy unter Apache 2.0.47
>
>
> > Hallo,
> >
> > nach dem Upgrade meines Reverse Proxies von apache 1.3.27 zu apache
2.0.47
> > habe ich Probleme mit Reverse-Proxy Verbindungen und redirects. Sobald
der
> > Server mit Hilfe des Location-Feldes im HTTP-Header ein redirect sendet,
> > wird dieser nicht neugeschrieben. Unter 1.3.27 hat dies funktioniert.
Ich
> > verwende die gleiche Konfiguration des Virtual Hosts:
> >
> > <VirtualHost 192.168.1.4:443>
> >
> >     DocumentRoot "/usr/local/apache2/htdocs"
> >     ErrorLog /usr/local/apache2/logs/error_log
> >     TransferLog /usr/local/apache2/logs/transfer_log
> >     SSLEngine on
> >     SSLProxyEngine on
> >     SSLCipherSuite
> > ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
> >     SSLCertificateFile /usr/local/apache2/conf/ssl.crt/xxx.crt
> >     SSLCertificateKeyFile /usr/local/apache2/conf/ssl.key/xxx.key
> >     ServerName richtigername.xxx.com
> >     ServerAdmin postmaster@xxx.com
> >     ProxyPass / http://XXXXXX:8000/
> >     ProxyPassReverse / http://XXXXXX:8000/
> >
> >   </VirtualHost>
> >
> > Sendet der Server "Location: http://XXXXXX:8000/bla" wurde dies unter
> 1.3.27
> > zu Location: https://richtigername.xxx.com/bla umgeschrieben. Unter
apache
> 2
> > bleibt das Location-Field unverändert.
> >
> > Übersetzt habe ich apache2 mit folgenden Optionen:
> >
> >
> >
>
./configure --enable-proxy --enable-ext-filter --enable-headers --enable-ssl
> >  --prefix=/usr/local/apache2
> >
> > Ich hoffe jemand kann mir helfen, da ich nicht mehr 1.3.27 einsetzen
kann.
> >
> > mfg fitz
> >
> >
> >
>


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message