httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Abele <e...@codefaktor.de>
Subject Re: AW: Wie bekomme ich das Modul zum Laufen
Date Fri, 16 May 2003 11:18:55 GMT
am 16.05.2003 12:31 Uhr schrieb Steffen Trenkler unter trenkler@syn-con.de:

> Modifiziere ich die Windows-httpd.conf entsprechend, dass dieses Modul
> geladen werden soll, funktioniert es nicht, weil es diese Modul-Datei im
> Verzeichnis "modules" gar nicht gibt.
> 
> Mein Verdacht geht dahin, dass Apache unter Windows nicht mit MIME umgehen
> kann. In meinen PHP-Skripten werden die Bilder in der Datenbank zusammen mit
> dem Dateityp gespeichert - z.B. "image/pjpeg" und "image/gif".

[snip]

> Warum gibt es in der httpd.conf unter Windows das Modul "mod_mime.so" und
> unter Windows nicht??????
 
Da dies ein Standard-Modul ist und zum Basis-Umfang von Apache gehört, ist
es unter Windows per default schon in die Apache.exe miteinkompiliert;
ansonsten wären solche Direktiven wie AddType, SetHandler oder TypesConfig
in der httpd.conf nicht anwendbar.

Du findest unter Windows also nur die sog. Erweiterungs- und
Experimental-Module als eigene so-Dateien / DLLs im 'modules'-Ordner. Die
restlichen Module aus der Base-Kollektion sind immer schon vorhanden und
müssen nicht extra geladen werden.

Cheers,
Erik

P.S.: Dies gilt nur für den 1.3er; beim 2.0er sind unter Win, soweit ich
weiss, alle Module als dynamische Libraries (*.so) vorhanden.


--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message