httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gatherer <gathe...@debis.com>
Subject apache2, mod_ldap,mod_auth_ldap, solairs 8
Date Tue, 15 Apr 2003 15:40:21 GMT
Hallo zusammen,

gibt es bekannte Probleme mit folgender Konstellation:

Apache/2.0.45
OpenLDAP 20116
Solaris 8

mod_ldap
mod_auth_ldap ?


./configure --with-ldap --enable-ldap --enable-auth-ldap  
--with-ldap-libs=/export/home/http/OPENLDAP/lib 
--with-ldap-include=/export/home/http/OPENLDAP/include


Compilieren und installieren kein Problem.
Richtigen Ldaplibs werden benutzt.

Beim Start wir unter /tmp die Datei mod_ldap_cache angelegt.
Diese hat die rechte des Apache-users.

Um den Status abzufragen:

<Location /ldap-status>
 
SetHandler ldap-status
Order allow,deny
Allow from all
 
</Location>

Ein Zugriff hierdrauf funktioniert auch, zeigt aber immer 0,0/0,0%,0, etc.

Wird nun auf ein Verzecihnis einen ACL gesetzt und der Zugriff darauf
versucht, so stirbt der verabeitende Child-Prozess mit "bus error (10)".

Und die ohne überhaupt eine Ldapanfrage zu versuchen.

Interessanter Weise kann man das Problem umgehen, wenn man vor dem
Start des Apache die Datei /tmp/mod_ldap_cache als root anlegt (touch)
und die Rechte für andere User eliminiert.

Somit funktioniert zwar der Cache nicht, aber die Ldapanfragen werden
gesendet und funtkionieren.


Ist das Problem bekannt ? Weiß sonst jemand einen Lösung ?

Danke im Voraus,

A. Waldmann

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message