httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rickauer, Stephan Andreas" <stephanandreas.ricka...@eds.com>
Subject Idle Slots verbrauchen 100% CPU
Date Fri, 28 Feb 2003 12:04:14 GMT
Hallo zusammen,

unser Webserver (Apache/1.3.23 (Unix) mod_ssl/2.8.7 OpenSSL/0.9.6c PHP/4.1.0
mod_perl/1.26 mod_gzip/1.3.19.1a) hat ein interessantes Langzeitproblem,
dass ich weder vollständig verstehe, noch in irgendeiner Mailingliste
gefunden oder im Inet ergooglen konnte.

Apache Konfiguration: StartServers 5, MinSpare 5, MaxSpare 10, KeepAlive on,
Timout 120, KeepaliveTimeout 15
Maschinen: Intel, Kernel 2.4.14-4GB, SuSE 8.0, 256MB, 1GHz Proz.

Das Szenario sieht wie folgt aus: ein Test-Client (Loadrunner) requested
konstant diverse PHP-Seiten (Typo3) über einen mehrstündigen Zeitraum von
einem Apache Server. Dabei sind die Antwortzeiten über viele Stunden
konstant, bei wenig Load (= ca. 12 Hits/Min, bei 1.9 Pageviews/Minute). Ab
einem gewissen Zeitpunkt (nicht exakt definiert, aber immer nach mehreren
Stunden) steigen die Antwortzeiten (bei gleichem Load) langsam an,
gleichzeitig konsumiert der entsprechende Apache-Child 100% CPU. Nach einer
gewissen Zeit nimmt ein weiterer Child Beschlag von der CPU, so dass sich
die beiden "durchdrehende" Children dann die CPU teilen (je 50%). So
skaliert es weiter. Beende ich die Requests des Test-Clients, bleiben die
"duchdrehenden" Children allerdings auf insgesamt 100%. Nur ein kill -9 auf
die entsprechenden Prozesse bzw. ein Restart des Apache-Servers schafft
Abhilfe.

Mir ist bewusst, dass dieses Szenario in der Realität eher weniger vorkommt,
da ein Slot nach dem TimeOut ja immer wieder frei wird und erneut von einer
anderen Verbindung benutzt wird. In diesem Fall wird ein Slot über mehrere
Stunden benutzt.

Sicher ist nur, dass die auf einer anderen Maschine laufende MySQL-DB nicht
in das Problem involviert ist. Ansonsten tippe ich auf PHP, was ich aber
auch nicht sicher sagen kann. Ob das Problem auch bei rein statischem
Content auftritt ist nicht anzunehmen, aber ebenfalls nicht sichergestellt.

Hier ein Link auf die entsprechende Loadrunner-Auswertung, die das Problem
veranschaulicht: http//sos.ethz.ch/~stef/typo3/

Bin um _jeden_ nützlichen Hinweis froh :) 

Mit freundlichen Grüssen,
Stephan A. Rickauer

--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message