httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max.Dittr...@t-online.de (Max Dittrich)
Subject Re: ScriptLog zeichnet nichts auf...
Date Mon, 06 Jan 2003 15:08:54 GMT
Hallo,

On 1/6/2003 3:21 PM, STAR Group Webmaster wrote:
> Hallo zusammen
> 
> auf unserem SUN Solaris Server mit Apache/1.3.27 will ich ein Logfile 
> fuer Scripts definieren.
> Das hab ich mit der ScriptLog Direktive gemacht und mit bin/apachectl 
> configtest resp. bin/apachectl restart den Server neu gestartet.
> Hat tip-top geklappt :).
> 
> Dann hab ich ein dummy Perlscript gemacht welches absichtlich ein Fehler 
> hat.
> Beim Aufruf gibt der Apache einen "500 Initial Server Error" zurueck.
> 
> Aber im ScriptLog file tut sich garnichts, wenn bei einem CGI Script 
> (Perl) ein Fehler auftritt - es bleibt bei 0 Bytes.
> Zugriffsberechtigungen sind auch ok!
> 
> Meiner Meinung nach sollte doch der Fehler im ScriptLog aufgezeichnet 
> sein, oder lieg ich da falsch???

AFAIR wenn dieses für den unter "User" konfigurierten Benutzer 
schreibbar ist.

> 
> httpd.conf:
> --- cut ---
[...]
> 
> # ScriptLog fuer CGI's
> #<IfModule mod_cgi.c>
> ScriptLog logs/script_log

und <ServerRoot>/logs wird wohl nicht für "www" o.ä. schreibbar sein?

> # Pro Eintrag maximal 1024 Bytes
> #ScriptLogBuffer 1024
> # Maximal 10 MB
> #ScriptLogLength 10385760
> #</IfModule>
> --- cut ---

gruss,
.max



--------------------------------------------------------------------------
                Apache HTTP Server Mailing List "users-de" 
      unsubscribe-Anfragen an users-de-unsubscribe@httpd.apache.org
           sonstige Anfragen an users-de-help@httpd.apache.org
--------------------------------------------------------------------------


Mime
View raw message