httpd-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Heiko Schubert <heiko...@ghost.tmt.de>
Subject Apache restartet nicht immer
Date Thu, 21 Feb 2002 08:53:08 GMT
Hallo Mitleser,

seit einigen Tagen habe ich ein Problem: 
Zwei meiner Apache (1* 1.3.22/Debian Protato, 1*1.3.20 Redhat 6.1)) haben 
gelegentlich das Problem, ordentlich zu restarten, nachdem ich die 
Logfiles rotieren lassen habe (6 Uhr früh). Der Restart des Webservers 
erfolgte wahlweise mit

/usr/local/apache/bin/apachectl graceful

oder

/etc/rc.d/init.d/apache stop
sleep 1
/etc/rc.d/init.d/apache start

Wenn ich das Problem bemerke (Apache war down) kann ich den Webserver 
problemlos "von Hand" starten.

Interessanterweise tritt das Problem 

* seit ein paar Tagen auf
* auf zwei Servern (identische Konfiguration)
* nur sporadisch, d.h. nicht immer

Ich betreue noch weitere Server mit identischer Konfiguration, kann aber 
bei denen das Problem nicht nachvollziehen. Komisch ... Was genau der 
Unterschied zwischen den Maschinen ist, vermag ich nicht mit Sicherheit 
zu sagen. Nur so viel: da gehen am Tag einige GB (ca.10) an Traffic 
rüber. Zum Zeitpunkt der Logfilerotation ist es aber "relativ" ruhig. 

Bei den Apachen handelt es sich um ein Lamp-System, welche wie folgt 
zusammengesetzt sind:

--- Auszug aus meinem congigure.sh - BEGIN ---
export SSL_BASE=/usr/local/src/openssl

./configure \
--prefix=/usr/local/apache \
--logfiledir=/var/log/apache \
--enable-module=so \
--enable-shared=rewrite \
--enable-module=rewrite \
--enable-module=ssl

--- Auszug aus meinem congigure.sh - ENDE ---


SSL habe ich nicht als Modul hinbekommen. Als ich es versucht hatte, 
konnte ich anschließend keinen key mehr generieren. :-( Hat hierzu 
vielleicht jemand einen Hinweis?

Nun ja, checke ich jetzt die Konfiguration (apachectl configtest), dann 
bekomme ich folgende Meldung:

Syntax error on line 11 of /etc/httpd/vhosts_ssl.txt:
Invalid command 'SSLEngine', perhaps mis-spelled or defined by a module 
not included in the server configuration

Die vhosts_ssl.txt (mittels include in die httpd.conf eingebunden) sieht 
wie folgt aus (IP's und Domaine geändert):

--- Auszug aus meinem vhosts_ssl.txt - BEGIN ---

NameVirtualHost 1.2.3.4:443

<VirtualHost 1.2.3.4:443>

SSLEngine on
SSLCertificateFile      /usr/local/apache/conf/ssl.crt/server.crt
SSLCertificateKeyFile   /usr/local/apache/conf/ssl.key/server.key

ServerAdmin    h.schubert@meine-domaine.ch
DocumentRoot   /www/ssl02.meine-domaine.ch/html
ServerName     ssl02.meine-domaine.ch
ErrorLog       /var/log/apache/ssl02-meine-domaine-ch-error_log
CustomLog      /var/log/apache/ssl02-meine-domaine-ch-access_log combined
</VirtualHost>

--- Auszug aus meinem vhosts_ssl.txt - ENDE ---

Ich verstehe das nicht. Das sollte eigentlich richtig sein. Des weiteren 
bin ich mir nicht einmal sicher, dass 

* die SSL-Konfiguration etwas mit dem Restart-Problem zu tun hat
* das Problem wirklich erst seit kurzem besteht

Ist jemand beim Lesen dieser Zeilen etwas aufgefallen? 

Ich bin für jeden Hinweis dankbar.

Bye,
	Heiko

Mime
View raw message