httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: loading mod_perl first?
Date Wed, 09 Feb 2005 23:15:05 GMT
Geoffrey Young wrote:

+1

> Index: TestRunPerl.pm
> ===================================================================
> --- TestRunPerl.pm	(revision 153110)
> +++ TestRunPerl.pm	(working copy)
> @@ -35,6 +35,9 @@
>  
>      # Apache::TestConfigPerl already configures mod_perl.so
>      Apache::TestConfig::autoconfig_skip_module_add('mod_perl.c');
> +
> +    # skip over Embperl.so - it's funky
> +    Apache::TestConfig::autoconfig_skip_module_add('Embperl.c');
>  }
>  
>  sub configure_modperl {
> Index: TestConfigPerl.pm
> ===================================================================
> --- TestConfigPerl.pm	(revision 153110)
> +++ TestConfigPerl.pm	(working copy)
> @@ -94,10 +94,7 @@
>          debug $msg;
>      }
>  
> -    # modules like Embperl.so need mod_perl.so to be loaded first,
> -    # so make sure that it's loaded before files inherited from the
> -    # global httpd.conf
> -    $self->preamble_first(IfModule => '!mod_perl.c', $cfg);
> +    $self->preamble(IfModule => '!mod_perl.c', $cfg);
>  
>  }
>  


-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message