httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: loading mod_perl first?
Date Thu, 10 Feb 2005 12:38:50 GMT
Hi,

> 
> > Index: TestRunPerl.pm
> > ===================================================================
> > --- TestRunPerl.pm	(revision 153110)
> > +++ TestRunPerl.pm	(working copy)
> > @@ -35,6 +35,9 @@
> >  
> >      # Apache::TestConfigPerl already configures mod_perl.so
> >      Apache::TestConfig::autoconfig_skip_module_add('mod_perl.c');
> > +
> > +    # skip over Embperl.so - it's funky
> > +    Apache::TestConfig::autoconfig_skip_module_add('Embperl.c');
> >  }
> >  

This solution looks good to me, but should be mod_embperl.c instead of
Embperl.c.

The reason why Embperl.so needs to loaded in the Apache config, is that it
adds Apache configuration directives to Apache, so you can write

Embperl_XXX foo

Instead of 

PerlSetEnv EMBPERL_XXX foo

In Apache 1.3 this works without explicitly loading Embperl.so, just via
PerlModule, but for Apache 2 Embperl.so needs to be loaded via LoadModule,
otherwise it's to late for adding config directives. So the problem will
occur with all modules that adds configuration directives to Apache and you
are right that is not common. The only one I know is AxKit, which currently
runs only on mod_perl 1.

Gerald

P.S. I am currently on the German Perl Workshop, so I cannot test. I will
test this change when I am back.





Mime
View raw message