httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: Apache2 / mod_perl1 confusion
Date Fri, 21 Jan 2005 14:26:53 GMT


Gavin Carr wrote:
> Hi all,
> 
> I'm trying to test a C module against both apache2 and apache1. apache1
> is working beautifully, but when I attempt to reconfigure for apache2
> (stock FC1), A::T (1.20) keeps complaining about finding mod_perl 1. I'm
> doing:
> 
>   ./TEST -clean
>   ./TEST -apxs /usr/sbin/apxs -conf

when I run tests against both apache 1 and apache 2 I generally 'make
realclean' and then re- "perl Makefile.PL -apxs..." and it works just fine.

if you look in t/TEST you'll probably see your old -apxs path in there.

well, that is, if you specified -apxs when building your Makefile :)
> 
> With -trace=debug on, I'm getting:
> 
> <lots snipped>
> [  debug] using httpd.conf inherited ServerRoot to resolve modules/mod_perl.so
> [  debug] modules/mod_perl.so successfully resolved to existing file /etc/httpd/modules/mod_perl.so

is that the right mod_perl location for your Apache 2 install?

things to check here are that t/conf/apache_test_config.pm is removed after
you run t/TEST -clean and what it contains after you run t/TEST -conf.

also, try nuking ~/.apache-test after t/TEST -clean and exporting
APACHE_TEST_NO_STICKY_PREFERENCES=1 before you try again.  part of the
reason why I coded APACHE_TEST_NO_STICKY_PREFERENCES was because sticky
preferences tend to get jumbled up when switching between versions (which I
do a lot :)

HTH

--Geoff

Mime
View raw message