httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Recent problem with Apache::Test v. 1.19
Date Thu, 13 Jan 2005 20:52:12 GMT
Christopher H. Laco wrote:
> Stas Bekman wrote:
> [snip]
> 
>> The requirement for Cwd 2.06 was needed to get the tests running under 
>> -T, which was otherwise blowing up (precisely under 5.6.x). If there are 
> 
> 
> Just for my learning, which version of -T?
> 
> [t/mytest.t]
> #!perl -wT
> use Apache::Test;
> 
> or
> 
> PerlTaint On
> 
> or
> 
> perl -wT t/TEST or make test?

There is only one version of taint, it doesn't matter how you invoke it.

It was blowing up when File::Spec::rel2abs was used. Search this list's 
archives for that module to find the right thread discussing this problem.

> In the project I'm currently working on, it's all running under 5.6.1 
> w/A-T 1.16, stock Cwd 2.04 without any blowups under the first and third 
> options.  All hell breaks loose when I try PerlTaint on, but those 
> appeared to be AxKit issue in my case.

The difference is not first/third vs. second, but plain perl vs. mod_perl. 
  Under mod_perl there are many things happening which don't happen under 
plain perl. The main cause is a persistance of things. So some totally 
unrelated code may cause taint problems. So you need to seek the cause and 
fix it.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message