httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject A-T: testmore failures
Date Mon, 20 Dec 2004 21:30:16 GMT
Geoff, when running A-T t/more:

[Mon Dec 20 16:04:12 2004] [error] [client] failed to resolve 
handler `TestMore::testmorepm': -withtestmore error: Test::Builder version 
0.18_01 required--this is only version 0.17 at 
/home/stas/ line 68.

% perl5.8.6 -MTest::More -le 'print Test::More->VERSION'

the problem is simple - A-T's test suite doesn't use Apache::TestRunPerl, 
so all the special stuff needed by modperl is not used. So it picks the 
default module it finds (if any). in this case it picks the wrong, and the server side ends up running under a different perl. 
So the client and server don't agree and this kind of failure happens.

So I think the only solution to this is enforce that A-T tests require 
installed modperl. or something else needs to be done with t/more.

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

View raw message