httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <>
Subject Re: need to require Cwd 2.06 for A-T
Date Thu, 02 Dec 2004 18:45:36 GMT

Stas Bekman wrote:
> Stas Bekman wrote:
>> I know we tried to avoid external dependencies, but Cwd coming with
>> 5.6.x is unusable under -T. At the moment this breaks some mp2 tests
>> (the problem comes from A-T, which indirectly invokes Cwd::cwd via
>> File::Spec's rel2abs. I've tried to code a workaround, but it doesn't
>> work and it's a bad idea to get it working since it's very OS
>> specific. (_backtick_pwd is the problem).
>> so we probably have no choice but require Cwd 2.06

if it's only breaking mp2 tests then those tests should probably have

  plan tests => $n, need_min_module_version(Cwd => 2.06);

instead of requiring an external dependency for the entire framework.

not that I'm against external dependencies, but we should only require an
external dependency when the codebase itself requires it.  that is, it is
your tests that need a higher Cwd, not Apache-Test proper.


View raw message