httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: need to require Cwd 2.06 for A-T
Date Thu, 02 Dec 2004 18:15:09 GMT
Stas Bekman wrote:
> I know we tried to avoid external dependencies, but Cwd coming with 
> 5.6.x is unusable under -T. At the moment this breaks some mp2 tests 
> (the problem comes from A-T, which indirectly invokes Cwd::cwd via 
> File::Spec's rel2abs. I've tried to code a workaround, but it doesn't 
> work and it's a bad idea to get it working since it's very OS specific. 
> (_backtick_pwd is the problem).
> 
> so we probably have no choice but require Cwd 2.06

So it's:

WriteMakefile(
     NAME      => 'Apache::Test',
     VERSION   => $VERSION,
     PREREQ_PM => { 'File::Spec' => '0.8',
                    'Cwd'        => '2.06',
                  },
...
);

but if this is not run from CPAN/CPANPLUS shell, most likely this 
requirement will be ignored. Should we add:

die "Cwd 2.06 or higher is required"
     unless eval { require Cwd && $Cwd::VERSION >= 2.06 };

after WriteMakefile(), this won't get on the way of CPAN/CPANPLUS shell 
will it?

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message