httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Problem building Apache::Test module on RHEL WS 3.0
Date Wed, 01 Dec 2004 21:05:38 GMT
Brian McEntire wrote:
[...]
> Invalid command 'TypesConfig', perhaps mis-spelled or defined by a 
> module not included in the server configuration
[...]
> TypesConfig "/tmp/Apache-Test-1.16/t/conf/mime.types"
> 
> 
> Is TypesConfig not recognized by Apache/2.0.46 (the latest Apache that 
> comes with RedHat Enterprise Linux Workstation version 3.0)?

It requires mod_mime to be available. Apparently you don't have it 
built-in or available as a module. So we need to enclose it in <IfModule 
mod_mime.c> </IfModule> block. You can do it manually just to check that 
this is the solution. But after that run:

   t/TEST

and not 'make test', since the latter will overwrite t/conf/httpd.conf.

Let us know whether this did the trick and we will adjust the code.

> I thought about exiting the t/conf/httpd.conf file but it says not to 
> right at the top.
> 
> Also, during make test, it asks where apxs is installed but says, "If 
> you don't have it installed it's not a problem. Just press Enter."
> 
> I don't know if that is related to this or not, but I did see APXS ... 
> failed messages during the make test.

As you can see it actually has found one: /usr/sbin/apxs. Is that a wrong 
apxs?


-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message