httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: failing httpd-test tests
Date Tue, 10 Aug 2004 13:17:16 GMT


Joe Orton wrote:
> On Mon, Aug 09, 2004 at 02:33:34PM -0700, Stas Bekman wrote:
> 
>>I have tested with a checkout from Aug 1 and t/modules/access fails just 
>>the same, so it's definitely unrelated to my changes over the weekend. I 
> 
> 
> I can't confirm that - the break occurs from the change between 18:00
> and 19:00 UTC on 6th August

which would seem to correspond to this comment:

"split the config object creation in 2 parts - first not requiring the
knowledge of httpd location, the second requiring one"

and the following change:

>   -    $self->configure_apxs;
>   -    $self->configure_httpd;
>   -    $self->inherit_config; #see TestConfigParse.pm
>   -    $self->configure_httpd_eapi; #must come after inherit_config
>   -
>        $self->default_module(cgi    => [qw(mod_cgi mod_cgid)]);
>        $self->default_module(thread => [qw(worker threaded)]);
>        $self->default_module(ssl    => [qw(mod_ssl)]);

which occurs in TestConfig::new(), which is now designated as

  # setup httpd-independent components
  # for httpd-specific call $self->httpd_config()

so I guess that assumption is wrong - default_module needs a complete httpd
setup to apply module naming magic, at least in cases where the module is
compiled in statically.

--Geoff

Mime
View raw message