httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Cooper <...@maxcooper.com>
Subject errors building flood --> /bin/sh: line 1: silent: command not found
Date Tue, 24 Aug 2004 00:29:07 GMT
I need a flood binary that I can run on my Linux box, but I am having
trouble building one.

I followed the build instructions on this web page:
http://httpd.apache.org/test/flood/building.html

apr and apr-util seem to build okay, but it looks like make is trying to
run some commands that don't make sense when it tries to build flood. I
believe the problem is with the build system rather than the flood
source code.

Here is the end of the build log:
make[1]: Leaving directory `/home/mcooper/httpd-test/flood/apr-util'
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood.c && touch flood.lo
/bin/sh: line 1: silent: command not found
make: [flood.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_round_robin.c && touch
flood_round_robin.lo
/bin/sh: line 1: silent: command not found
make: [flood_round_robin.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_profile.c && touch
flood_profile.lo
/bin/sh: line 1: silent: command not found
make: [flood_profile.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_config.c && touch
flood_config.lo
/bin/sh: line 1: silent: command not found
make: [flood_config.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_net.c && touch flood_net.lo
/bin/sh: line 1: silent: command not found
make: [flood_net.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_net_ssl.c && touch
flood_net_ssl.lo
/bin/sh: line 1: silent: command not found
make: [flood_net_ssl.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_farmer.c && touch
flood_farmer.lo
/bin/sh: line 1: silent: command not found
make: [flood_farmer.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_simple_reports.c && touch
flood_simple_reports.lo
/bin/sh: line 1: silent: command not found
make: [flood_simple_reports.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_easy_reports.c && touch
flood_easy_reports.lo
/bin/sh: line 1: silent: command not found
make: [flood_easy_reports.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_farm.c && touch flood_farm.lo
/bin/sh: line 1: silent: command not found
make: [flood_farm.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_socket_generic.c && touch
flood_socket_generic.lo
/bin/sh: line 1: silent: command not found
make: [flood_socket_generic.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_socket_keepalive.c && touch
flood_socket_keepalive.lo
/bin/sh: line 1: silent: command not found
make: [flood_socket_keepalive.lo] Error 127 (ignored)
silent --mode=compile gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -c flood_report_relative_times.c &&
touch flood_report_relative_times.lo
/bin/sh: line 1: silent: command not found
make: [flood_report_relative_times.lo] Error 127 (ignored)
silent --mode=link gcc    -g -O2      -I.
-I/home/mcooper/httpd-test/flood -o flood flood.lo flood_round_robin.lo
flood_profile.lo flood_config.lo flood_net.lo flood_net_ssl.lo
flood_farmer.lo flood_simple_reports.lo flood_easy_reports.lo
flood_farm.lo flood_socket_generic.lo flood_socket_keepalive.lo
flood_report_relative_times.lo
make: silent: Command not found
make: [flood] Error 127 (ignored)

I have attached a complete log (gzipped to avoid busting the 100K email
message size limit for this list) of my attempt to checkout and build
flood if you need more details. I did a uname -a at the beginning of the
session. I have tried to build on several different Linux boxes (Fedora
Core 2, Mandrake 10.0), and I got the same results on both.

I don't know what to do to resolve this. What can I do to get the build
working? Do I need a specific version of APR? A specific version of
flood?

Thanks,
-Max

-- 
Max Cooper <max@maxcooper.com>

Mime
View raw message