httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Apache-Test module skeletons
Date Fri, 09 Jul 2004 21:03:53 GMT
On Fri, 9 Jul 2004, David Wheeler wrote:

> On Jul 9, 2004, at 1:45 PM, David Wheeler wrote:
>
> > use 5.00503;
> > use Apache::TestMB;
> >
> > Apache::TestMB->new(
> >     module_name    => 'Apache::Test::Skeleton',
> >     license        => 'perl',
> >     requires       => { 'mod_perl'   => ">= 1.0, < 1.99",
> >                       },
> >     build_requires => { Test::More => 0,
> >                       },
> > )->create_build_script;
>
> Oh, and FWIW, CPANPLUS should soon have the ability to check such a
> spec. Not sure that CPAN.pm ever will, though.
>
> Regards,
>
> David

But won't the CPAN indices (which are used by both CPAN.pm
and CPANPLUS.pm) still just recognize one version of
mod_perl.pm? Either the current one associated with mp1, or,
when mp2 is out of development, that associated with mp2
(assuming mod_perl.pm of mp2 has a higher version compared
to that of mp1). Or will CPANPLUS go beyond the CPAN
indices?

One (qualitatively similar) example is the GD module, for
which there's two major (incompatible) versions, 1 and 2.
Currently CPAN.pm reports GD as being version 2.12, and so
to install an earlier version 1.x, you have to tell CPAN.pm
explicitly which distribution you want to install.

-- 
best regards,
randy

Mime
View raw message