httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@kineticode.com>
Subject Re: Apache-Test module skeletons
Date Fri, 09 Jul 2004 21:07:29 GMT
On Jul 9, 2004, at 2:03 PM, Randy Kobes wrote:

> But won't the CPAN indices (which are used by both CPAN.pm
> and CPANPLUS.pm) still just recognize one version of
> mod_perl.pm? Either the current one associated with mp1, or,
> when mp2 is out of development, that associated with mp2
> (assuming mod_perl.pm of mp2 has a higher version compared
> to that of mp1). Or will CPANPLUS go beyond the CPAN
> indices?

That I don't know. I would ask the CPANPLUS developers.

   http://cpanplus.sourceforge.net/

> One (qualitatively similar) example is the GD module, for
> which there's two major (incompatible) versions, 1 and 2.
> Currently CPAN.pm reports GD as being version 2.12, and so
> to install an earlier version 1.x, you have to tell CPAN.pm
> explicitly which distribution you want to install.

Right, the indexing is still a problem. However, for those who have the 
proper mp installed already, it should just work. And for those who 
don't, installation should fail, but they'll be told why.

But I agree that the indexing issue is important. Perhaps there should 
be a META.yml rule to tell CPAN what to index, so as to keep track of 
older versions of modules for those that really need to?

I dunno. Something to ask Jarkko about.

Regards,

David


Mime
View raw message