httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@kineticode.com>
Subject Re: Apache-Test module skeletons
Date Fri, 09 Jul 2004 20:45:43 GMT
On Jul 9, 2004, at 1:38 PM, Stas Bekman wrote:

> It won't work since the version number lives in the package mod_perl. 
> and most likely you'd want to require a minimal version at some point.

Ah, but this is one of the beauties of Module::Build, my friends. 
Behold!

use 5.00503;
use Apache::TestMB;

Apache::TestMB->new(
     module_name    => 'Apache::Test::Skeleton',
     license        => 'perl',
     requires       => { 'mod_perl'   => ">= 1.0, < 1.99",
                       },
     build_requires => { Test::More => 0,
                       },
)->create_build_script;

:-)

David


Mime
View raw message