httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject Re: cvs commit: httpd-test/perl-framework/Apache-Test/lib/Apache
Date Sat, 31 Jul 2004 17:05:07 GMT
Stas Bekman wrote:
> But, yes, the transition could be made 100% perfect, by keeping have_ as 
> it is, and adding a new interface which doesn't add the skip reason. But 
> we need to find an unambiguous name for it. skip_foo will be good, but 
> we have a general function have(), which can't be replaced with skip(). 
> So may be want_foo() is a better choice. Or may be you have a better 
> name...

Sorry, that last para is contradicting itself. So again, I suggest to 
keep have_lwp, and remove the skip functionality from it, e.g.:

   # Always allow redirection.
   my $redir = have_lwp ? [qw(GET HEAD POST)] : 1; # no skip
   Apache::TestRequest::user_agent(reset => 1,
                                     requests_redirectable => $redir);

but having a new function that will be have_foo+skip:

plan tests => 5, need_lwp, need_cgi, need_php;


plan tests => 5, want ['cgi', 'lwp'];

so require_ won't work too, as we will need a standalone word too. I 
think need_ or want_, or must_ pretty intuitive in the plan context.

or may be add must_have_*, so have_* is for checking, and must_have_* is 
checking and requiring. may be it's too long to type, but I like it.

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

View raw message