httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: A::T :withtestmore
Date Sun, 11 Jul 2004 20:45:30 GMT
On Sat, Jul 10, 2004 at 03:10:11PM -0400, Geoffrey Young wrote:
> I couldn't get that patch to apply to current cvs.

Maybe that's my problem. I applied the patch to the Test.pm from 1.12
release.


> > However, I'm still not getting the expected
> > results. I suppose that could be the fuzz factor you mentioned but put
> > together a new version of my test package in case you want to see if I'm
> > just doing something stupid[1].
> 
> well, I get the same results, and I can't see offhand what you are doing
> wrong.  but I started a tarball from scratch and was able to get it working
> with no problem at all.  so, try this tarball
> 
>   http://perl.apache.org/~geoff/testmore-geoff.tar.gz

Thanks. This works for me too so I guess the patch works against the
1.12 version. I checked the error logs and found the following
difference in mine:

  [Sun Jul 11 16:31:59 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
  Warning: Use of "require" without parentheses is ambiguous at (eval 12) line 1.
  [Sun Jul 11 16:32:01 2004] [error] Undefined subroutine &TestApache::My::Bug::bug-tm::handler
called.\n
  [Sun Jul 11 16:32:01 2004] [info] removed PID file /home/william/perl/bug-reporting-skeleton-mp1/t/logs/httpd.pid
(pid=2537)


Do you see this error when you run my package?

This makes me think that there may be a problem in the bug testing
framework itself when used in conjunction with the -testmore action. I
don't see a require statement in Bug.pm so am at a loss to say why this
would be failing. I tried changing the name of bug-tm.pm to bug_tm.pm in
case the hypen was a problem; it didn't help. Any other ideas?


Thanks,
William

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message