httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <>
Subject Re: cvs commit: httpd-test/perl-framework/Apache-Test/lib/Apache
Date Sat, 31 Jul 2004 23:40:39 GMT
On Jul 31, 2004, at 9:46 AM, Stas Bekman wrote:

> to me, got and have are exactly the same thing. How are you going to 
> remember which one to use when?

Yes, I will. :-)

> Authors of the existing tests don't have to change anything, have_foo 
> will work just the same, but won't add the skip reason anymore. This 
> won't make affect the existing tests in any way, rather than not 
> printing the reason for a tests being skipped.

Isn't that rather significant?

> But, yes, the transition could be made 100% perfect, by keeping have_ 
> as it is, and adding a new interface which doesn't add the skip 
> reason. But we need to find an unambiguous name for it. skip_foo will 
> be good, but we have a general function have(), which can't be 
> replaced with skip(). So may be want_foo() is a better choice. Or may 
> be you have a better name...

I thought I did. Hrm...

> or may be add must_have_*, so have_* is for checking, and must_have_* 
> is checking and requiring. may be it's too long to type, but I like 
> it.

That's similar to have in the same way got is. Are you going to 
remember which is which?

I guess losing the skip message by making need_ functions that replace 
the existing have_ functions is okay. It's most important that tests 
continue to pass...



View raw message