httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: [RELEASE CANDIDATE] Apache-Test-1.06
Date Thu, 20 May 2004 15:08:13 GMT
> please take the time to excercise the candidate through all your existing
> applications that use Apache-Test and report back successes or failures.

I had errors during testing which appear to be due to problems with the
auto configuration. Here's the steps I used:

    perl Makefile.PL
    make
    make test

Here's the output of the last command:

   /usr/bin/perl -Iblib/arch -Iblib/lib \
   t/TEST -clean
   setting ulimit to allow core files
   ulimit -c unlimited; /usr/bin/perl /home/william/perl/Apache-Test-1.11-dev/t/TEST -clean
   APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= APACHE_TEST_USER= APACHE_TEST_APXS=
\
   /usr/bin/perl -Iblib/arch -Iblib/lib \
   t/TEST -bugreport -verbose=0 
   setting ulimit to allow core files
   ulimit -c unlimited; /usr/bin/perl /home/william/perl/Apache-Test-1.11-dev/t/TEST -bugreport
-verbose=0
   configure() has failed: Use of uninitialized value in subroutine entry at lib/Apache/TestConfig.pm
line 1006.
   
   forcing Apache::TestConfig object save
   run 't/TEST -clean' to clean up before continuing
   +-----------------------------------------------------+
   | To report problems please refer to the SUPPORT file |
   +-----------------------------------------------------+
   make: *** [run_tests] Error 1


However everything works fine with the following command:

    perl Makefile.PL --httpd /usr/local/apache/bin/http
    make
    make test

So, it appears that the configurator is not working for me.



William

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message