httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: httpd test (perl-framework)
Date Thu, 15 Apr 2004 19:19:43 GMT
Abhishek Khandelwal wrote:
> I dont see any difference in two files.
> 
> I runt the test twice to do a test coverage analysis.
> At first, I install and test apache without test coverage
> and then I again install and test with test-coverage enabled.
> Second time, I get this error.

Aha, you should have mentioned that in first place. In which case that's your 
problem. With test-coverage enabled you don't get mod_access loaded. I don't 
know why. Not an Apache-Test problem I think.

> Moreover, this is just not doing with test-coverage.
> It happens quite often and without any predictablility.
> I am not sure how to reproduce it. Because it may or may not give me
> this error.

We need to be able to reproduce it in order to fix it. If we can't we can't 
fix it, since we don't know what the problem is.

I doubt it has something to do with sticky configuration, but give it a try 
and try to run with:

APACHE_TEST_NO_STICKY_PREFERENCES=1 make test

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message