httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: cvs commit: httpd-test/perl-framework/Apache-Test/lib/Apache TestConfig.pm
Date Thu, 01 Apr 2004 17:53:17 GMT
geoff@apache.org wrote:
> geoff       2004/04/01 06:32:03
> 
>   Modified:    perl-framework/Apache-Test/lib/Apache TestConfig.pm
>   Log:
>   trap require Apache::Build errors - not everyone has mod_perl 2.0 installed
>   
>   Revision  Changes    Path
>   1.215     +1 -1      httpd-test/perl-framework/Apache-Test/lib/Apache/TestConfig.pm
>   
>   Index: TestConfig.pm
>   ===================================================================
>   RCS file: /home/cvs/httpd-test/perl-framework/Apache-Test/lib/Apache/TestConfig.pm,v
>   retrieving revision 1.214
>   retrieving revision 1.215
>   diff -u -r1.214 -r1.215
>   --- TestConfig.pm	31 Mar 2004 22:44:32 -0000	1.214
>   +++ TestConfig.pm	1 Apr 2004 14:32:03 -0000	1.215
>   @@ -29,7 +29,7 @@
>        eval { require mod_perl && $mod_perl::VERSION >= 1.99 } || 0;
>    
>    use constant IS_MOD_PERL_2_BUILD => IS_MOD_PERL_2 &&
>   -    require Apache::Build && Apache::Build::IS_MOD_PERL_BUILD();
>   +    eval { require Apache::Build && Apache::Build::IS_MOD_PERL_BUILD() } ||
0;

Something is not right here, Geoff. It require()s *only* if IS_MOD_PERL_2 is 
true. Which must have Apache::Build present. I suggest that you try to revert 
it and find the real cause of the problem, rather than hide it. Thanks.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message