httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: testing apache 1.3 on windows
Date Mon, 22 Mar 2004 20:20:28 GMT
Geoffrey Young wrote:
> 
> Stas Bekman wrote:
> 
>>Rodent of Unusual Size wrote:
>>
>>
>>>Stas Bekman wrote:
>>>
>>>
>>>>does this make any difference/
>>>>
>>>>perl Makefile.PL -apxs K:/Coar/Apache/Server-1.3/bin/apxs.pl -httpd
>>>>K:/Coar/Apache/Server-1.3/bin/Apache.exe
>>>
>>>
>>>
>>>yes, it made a difference -- but it still didn't work.  it now
>>>specifies '-D APACHE1' correctly -- 
>>
>>
>>OK, so this is a known issue. Geoff was saying that he will post a
>>reproducable case so I can fix that. I suppose that since Geoff has
>>added the band-aid to turn the feature off we won't see that case ;)
> 
> 
> well, I implemented the feature but I have yet to turn it on outside of my
> test case :)

> sorry I haven't followed up - I've been swamped lately and am trying to
> catch up.  hopefully I'll be able to track it down "soonish"

Take your time, Geoff. I've reviewed the custom config loading code again and 
I do handle this case, but I must have omitted some situation I haven't 
thought of. I think the problem happens when the options are saved, not when 
they are read. So I won't be surprised that you will report that you get 
TestConfigData.pm containing discrepancy between apxs and httpd, as the cause 
of the problem.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message