httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Using A::T on Windows
Date Sat, 13 Mar 2004 01:26:05 GMT
William McKee wrote:
> Hi Folks,
> 
> I'm trying to get A::T running under Windows. Besides the recent rash of
> troubles I've had with TestRun.pm, my tests are successfully running
> under Linux.
> 
> Here's the error message I'm receiving when running `make test`:
> 
>   [  error] configure() has failed:
>   Can't locate mod_perl.pm in @INC (@INC contains: C:\Tiger-0.01\blib\lib C:\Tiger
>   -0.01\blib\arch lib blib\arch blib\lib c:\Tiger-0.01\lib\perl5.8.3 C:/Perl/lib C
>   :/Perl/site/lib .) at c:\Tiger-0.01\lib\perl5.8.3/Apache/TestConfigPerl.pm line
>   486, <GEN11> line 68.
> 
> 
> Here's my environment:
>     Windows XP
>     ActiveState Perl 5.8.3 (build 809)
>     Apache 2.0.48 (plain -- no modperl)
> 
> 
> It's my understanding that A::T should work w/o modperl. Is the above
> error a logical error? The code looks like it's testing the environment.

I suspect that you are subclassing ModPerl::TestRun instead of 
Apache::TestRun. The former requires mod_perl, the latter doesn't not.
ModPerl::TestRun is a subclass of Apache::TestRun

I don't think this is documented anywhere, so please, as you discover things, 
send patches to testing.pod, so you and others won't have to do it again. Thanks.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message