httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: Failures in TestRun.pm with A::T 1.09
Date Sat, 13 Mar 2004 03:35:08 GMT
On Fri, Mar 12, 2004 at 07:01:29PM -0800, Stas Bekman wrote:
> Why do you have /usr/lib/libperl.* at all? It's a bad idea to have it in 
> the common path if you have more than one perl installed on the same system.
> 
> Yes, you always need to rebuild mod_perl with the new version of perl.

I must not be building this correctly because I get the following error
message if I don't create the libperl.so and symlink it into
/usr/lib/libperl.so:

  error while loading shared libraries: libperl.so: cannot open shared
  object file: No such file or directory

I can't find anything about this error in the docs or via Google. Would
appreciate any insights you may have.



> All I'm worried about is that you may have too many perls installed under 
> the same tree or on the same system, and when you use them they get 
> intermixed causing weird problems. So I'd suggest to completely nuke (after 
> backuping) /usr/local/lib/perl5 and any other places you may have remains 
> of perl including libperl.* and install a fresh perl, rebuild mod_perl and 
> then give it a try.

Yeah, that's certainly a concern. I'd like to figure out my
misconfiguration issue above then will attempt your proposal to nuke all
these old installations and start fresh.


Thanks,
William

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message