httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: Failures in TestRun.pm with A::T 1.09
Date Thu, 11 Mar 2004 07:34:58 GMT
On Wed, Mar 10, 2004 at 10:41:15PM -0800, Stas Bekman wrote:
> % perl -V

Summary of my perl5 (revision 5.0 version 8 subversion 2) configuration:
  Platform:
    osname=linux, osvers=2.4.23, archname=i686-linux
    uname='linux vulcan 2.4.23 #1 wed dec 3 22:52:28 est 2003 i686 gnulinux '
    config_args='-Duseshrplib -Dotherlibdirs=/usr/share/perl5/ -de'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O3',
    cppflags='-fno-strict-aliasing -I/usr/local/include'
    ccversion='', gccversion='2.95.4 20011002 (Debian prerelease)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.3.2.so, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version='2.3.2'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic -Wl,-rpath,/usr/local/lib/perl5/5.8.2/i686-linux/CORE'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: USE_LARGE_FILES
  Built under linux
  Compiled at Dec 16 2003 17:36:57
  @INC:
    /usr/local/lib/perl5/5.8.2/i686-linux
    /usr/local/lib/perl5/5.8.2
    /usr/local/lib/perl5/site_perl/5.8.2/i686-linux
    /usr/local/lib/perl5/site_perl/5.8.2
    /usr/local/lib/perl5/site_perl
    /usr/share/perl5/
    .


> Since, I can't reproduce it, I'm not sure what is abnormal about your perl, 
> I'd suggest to start truncating the code that fails, till you get to the 
> smallest possible case which you will be able to reproduce in a standalone 
> script. Then we can ask p5p if there is some sort of bug, triggered in 
> certain cases.

I copied the entire list of modules and the set_ulimit_via_sh function
into a test script but was unable to reproduce the problem. Also tried
messing with eval{} to no avail.

I was able to find another poor soul who has experienced my pain[1].
Unfortunately there was no solution. Found several threads from back in
the mid-90's which addressed several problems before the die, warn and
carp statements were allowed to come after an exec w/o triggering the
warning message. Still not enough to help me reproduce the error when
running with TEST.


William


[1]
http://mathforum.org/epigone/mason/galdcungjom/r02000200-1028-CA6748AE3FB111D892A600039375B1D6@%5B192.168.2.10%5D

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message