httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject [PATCH] fix @INC when running all.t
Date Fri, 27 Feb 2004 09:52:13 GMT
The all.t tests are all failing for me on HEAD with errors like:

Can't locate Apache/Test.pm in @INC (@INC contains: ../Apache-Test/lib 
/usr/lib/perl5/5.8.1/i386-linux-thread-multi /usr/lib/perl5/5.8.1 
etc etc .) at 
t/ssl/all.t line 4.

from an strace, the cwd of the process is the top-level perl-framework
directory, so INC should be pointed at the Apache-Test subdir directly
rather than ../Apache-Test.

It works if you also have Apache-Test installed in the system site_perl
directory of course, which I have on most boxes so only just noticed
this.  This fixes it for me, OK to checkin?

Index: Apache-Test/lib/Apache/TestHarness.pm
===================================================================
RCS file: /home/cvs/httpd-test/perl-framework/Apache-Test/lib/Apache/TestHarness.pm,v
retrieving revision 1.15
diff -u -r1.15 TestHarness.pm
--- Apache-Test/lib/Apache/TestHarness.pm	23 Feb 2004 20:37:39 -0000	1.15
+++ Apache-Test/lib/Apache/TestHarness.pm	27 Feb 2004 09:43:53 -0000
@@ -49,7 +49,7 @@
 sub run_t {
     my($self, $file) = @_;
     my $ran = 0;
-    my $cmd = "$^X -Mlib=../Apache-Test/lib $file";
+    my $cmd = "$^X -Mlib=Apache-Test/lib $file";
 
     my $h = Symbol::gensym();
     open $h, "$cmd|" or die "open $cmd: $!";

Mime
View raw message