httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: sticky preferences in Apache-Test
Date Tue, 13 Jan 2004 19:16:43 GMT
On Tue, 13 Jan 2004, Stas Bekman wrote:

> Geoffrey Young wrote:
[ ... ]
> > what I do know, however, is that my nightly builds start
> > with 2.1 then move to 2.0, issuing 'make realclean'
> > between each.  for the past few nights, the 2.0 tests
> > don't run because it's loading TestConfigData.pm from my
> > global @INC.  at that point, TestConfigData.pm is from
> > the last install, which is a 2.1 install.
> >
> > this seems wrong to me - I have no remedy short of removing
> > TestDataConfig.pm between builds - at I think it would affect users that
> > upgrade as well.
>
> Are you sure that your not problem is elsewhere? I see
> this issue too though with non-mp2 build, just didn't have
> a chance to work on it yet.
>
> How do you build your mp2? It should ignore the custom
> config already, there must be some glitch.

I haven't worked through this yet, but I find a similar
problem ... I have two Perls, both of which have mp2
installed, but one has the CPAN Apache-Test and the other
has the cvs Apache-Test installed. In building the
cvs Apache-Test, I get the first-time dialogue with
the perl with the CPAN Apache-Test installed, but don't
get the dialogue with the perl with the cvs Apache-Test
installed. I'm a bit baffled as to why, as this occurs
even if I delete the system TestConfigData.pm.

-- 
best regards,
randy

Mime
View raw message