httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: Perl test framework, TestConfig, and debugging A::T
Date Sun, 18 Jan 2004 15:37:20 GMT
On Sun, Jan 18, 2004 at 12:38:15AM -0800, Stas Bekman wrote:
> >William, the cvs version of Apache-Test now has this bug solved. So if 
> >you want to use that APACHE solution try it. Though the suggested above 
> >solution is more efficient, as it won't reconfigure the test suite on 
> >every t/TEST run.

Thanks. I have switched my habits as you suggested and am glad to be
taking advantage of the more efficient route. I stopped
using the solution of passing the httpd path into the Makefile.PL
command because it stopped working for me. I suspect that I forgot to
include the Apache::TestMM::filter_args() module :(.

I'll second the motion that Geoff's article and skeleton frameworks
should be mentioned at the top of the perl.apache.org testing document
(not just listed in the References). His article is better laid out for
newcomers like myself to get into this framework without having to
understand all of the ins and outs that have been documented on the
"Running & Developing..." page. That page is an awesome resource once
someone has a basic environment working and is ready to do more advanced
testing.


> Though I've also changed the env variables in the cvs version:

No problems. I'd prefer to reconfigure my systems to maintain
consistency across the testing environment.


Cheers!
William

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message