httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: Perl test framework, TestConfig, and debugging A::T
Date Fri, 16 Jan 2004 18:47:53 GMT
On Fri, Jan 16, 2004 at 01:03:00PM -0500, William McKee wrote:
> On Thu, Jan 15, 2004 at 04:24:41PM -0800, Stas Bekman wrote:
> > I don't have apache 1.3 with ssl so I can't test it. And it doesn't quite 
> > work with apache/mp 2.0 because you have hardcoded mp1 API. Please see the 
> > porting doc: http://perl.apache.org/docs/2.0/user/porting/porting.html
> > http://perl.apache.org/docs/2.0/user/porting/porting.html#Making_Code_Conditional_on_Running_mod_perl_Version
> 
> Oops. Nice info in the links.

While trying to implement this checking in my Apache::TestTest module, I
had problems with the following pragmas:

    use Apache::Const -compile('OK');
    use Apache::Constants ':common';

Because we must convert use to require to do the testing, I had to then
run the import command to get the common tags into my module's
namespace.

After that everything worked. I haven't tested under MP2 and was only
guessing about my conversion so you may need to make some modifications
to the module before testing the latest release[1]. I'd appreciate your
feedback on my conversion efforts to support both mp1 and mp2. (Yeah, I
know that I should install a test server locally. Too many things to
do!).


Thanks,
William

[1] http://www.knowmad.com/~william/Apache-TestTest-0.03.tar.gz

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message