httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: Perl test framework, TestConfig, and debugging A::T
Date Thu, 15 Jan 2004 03:18:39 GMT
On Wed, Jan 14, 2004 at 11:21:13AM -0800, Stas Bekman wrote:
> >>and Apache::Test->config in perl files:
> >>my $dir = catdir Apache::Test::config()->{vars}->{documentroot}, '...',
> >>
> >>We need better docs for this configuration issue. Patches are very 
> >>welcome.
> >
> >
> >I'm not sure I follow your comment. Am I misusing this somewhere?
> 
> Yup:
> 
> conf/startup.pl:/home/william/perl/Apache-TestTest/lib
> 
> but it shouldn't be there at all, since that's the whole point of 
> APACHE_TEST_LIVE_DEV=1

I'm afraid I still don't understand what you mean here. I have removed
the use lib statement from my startup perl scripts but still am getting
the test which checks the APACHE_TEST_LIVE_DEV setting to fail.

I have modified my test module per your suggestions, successfully tested
it in /tmp on my system and uploaded it back to my server[1]. Thanks
again for your time in helping me get a handle on this stuff.

I've attached a diff of a few changes (mostly typos) I made to the
testing page on the server. I'll try to add more as we go through the
problems I'm having with my tests.

Thanks,
William

[1] http://www.knowmad.com/~william/Apache-TestTest-0.02.tar.gz

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message