httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [mp2] message about Invalid command 'PerlSwitches' during make test
Date Sat, 18 Oct 2003 04:38:55 GMT
Geoffrey Young wrote:
> 
>>> So it would appear that I want to build mod_perl without the
>>> MP_USE_STATIC=1, is that correct?
>>
>>
>>
>> That's right. I should have noticed that in your bug report. The 
>> static build is not completed yet. I guess we should do more checking. 
>> Meanwhile just remove that MP_USE_STATIC=1, it'll use MP_USE_DSO=1 by 
>> default.
> 
> 
> I'm thinking about adding some stuff to TestReport, namely httpd -l
> but perhaps also a list of the .so files in modules/

That wouldn't have helped in this particular case, but it certainly could be 
helpful in the future? If you add it, it should probably come last? (may be 
just switch perl and apache sections places?) most problems so far had to do 
with the way perl was built, so it'd be nice to have it just after the 
mod_perl config bits.

If you are working on it, please add another important bit, the path to the 
system's httpd.conf A-T has inherited from, since quite a few problems were 
related to this file. Thanks Geoff.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


Mime
View raw message