httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject Re: [cpan #3861] Custom t/conf/ is ignored
Date Wed, 01 Oct 2003 23:29:42 GMT
> This message about Apache-Test was sent to you by guest <> via
> Full context and any attached attachments can be found at:
> <URL: >
> After getting past the hurdle of notifying A::Test of the path to my 
> httpd daemon, I now get the following error when testing:
> ---------------------------------------------
> waiting for server to start: .Syntax error on line 10 of 
> /root/.cpan/build/Apache-Test-1.03/t/conf/httpd.conf:
> Cannot load /usr/lib/apache/1.3/ into server: 
> /usr/lib/apache/1.3/ undefined symbol: ap_hook_status
> !!!
> server has died with status 1 (t/logs/error_log wasn't created, start 
> the server in the debug mode)
> ---------------------------------------------
> Apparently my server needs to be configured for DSO support and have its 
> modules compiled as DSO's. None of the docs mentioned these requirements 
> and it is a surprising one given the fickleness of running mod_perl as a 
> DSO (which is why all of my modules are compiled into the daemon).

No, as mentioned in the other followup. it inherits the httpd.conf settings 
from your global httpd.conf.

> Anyhow, I saw in the README that I could create a custom httpd.conf file 
> to use for testing. I copied the default t/conf/httpd.conf to 
> t/conf/ and removed the calls to LoadModule. I even deleted 
> the original t/conf/httpd.conf file. However, my changes in the 
> file were ignored when the new httpd.conf file was 
> generated. Apparently the test is not using this file as its source for 
> generating the httpd.conf file.
> Thanks,
> William


Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

View raw message